
 

 

 

 

 

 

 

 

 

 



What is Quad Store's Uno R3 open source Arduino-Compatible board ?   

Uno R3 is based on opensource hardware platform which means the design is made publicly 
available so that anyone can study, modify, distribute, make, and sell the design or hardware based 
on that design. Quad Store's Uno R3 board is made in a similar fashion which is more focused on 
providing "Quality" boards rather that the cheap clones. 

Our boards are 100% compatible with arduino IDE, sensors and codes. 

Why Quad Store's Uno R3 board?  

Advantages: 

1. Board is made of black pcb with gold plated technology which is the best in terms of industrial 
standards quality and can provide long life. It is 100% compatible with arduino IDE, sensors and 
codes. 
2. Color Pin Head for Easy Identification Red for Power Section, Blue for Analog I/O, Green for 
Digital I/O.  
3. This makes it really easy to figure out where to connect sensors, or to identify which side is 
Analog (blue) or Digital (green) 
4. Package comes with USB cable. 
5. Quality check on each board to make sure the bootloaders are up to date. 

 

Introduction: Installing IDE 
 

STEP-1: Download the Arduino IDE (Integrated Development Environment) 

 

Access the Internet: 

In order to get your Arduino up and running, you'll need to download some software first from 

www.arduino.cc (it's free!). This software, known as the Arduino IDE, will allow you to program the 

Arduino to do exactly what you want. It’s like a word processor for writing programs. With an 

internet-capable computer, open up your favorite browser and type in the following URL into the 

address bar: 

 

www.arduino.cc/en/Main/Software 

 

http://www.arduino.cc/en/Main/Software


 
 

 

 
 

 

For different operating system platforms, the way of using Arduino IDE is different. Please refer to 

the following links: Windows User：http://www.arduino.cc/en/Guide/Windows Mac OS X  

User：http://www.arduino.cc/en/Guide/MacOSX Linux 

User：http://playground.arduino.cc/Learning/Linux For more detailed information about Arduino 

IDE, please refer to the following link: http://www.arduino.cc/en/Guide/HomePage 

 

 

 

STEP-2: Connect your Arduino Uno to your Computer: 

 
Use the USB cable provided in the kit to connect the Arduino to one of your computer’s USB inputs. 

 

http://www.arduino.cc/en/Guide/HomePage


 

 
 

 

STEP-3: Install Drivers 

Depending on your computer’s operating system, you will need to follow specific instructions. 

Please go to the URLs below for specific instructions on how to install the drivers onto your Arduino 

Uno. 

 

Windows Installation Process: 

Go to the web address below to access the instructions for installations on a Windows-based 

computer.  

 

http://arduino.cc/en/Guide/Windows 

 

Macintosh OS X Installation Process: 

Macs do not require you to install drivers. Enter the following URL if you have questions. Otherwise 

proceed to next page. 

  

http://arduino.cc/en/Guide/MacOSX 

 

Linux:  

32 bit / 64 bit, Installation Process Go to the web address below to access the instructions for 

installations on a Linux-based computer. 

 

http://www.arduino.cc/playground/Learning/Linux 

 

 

STEP-4: Open the Arduino IDE 

Open the Arduino IDE software on your computer. Poke around and get to know the interface. 

We aren’t going to code right away, this is just an introduction. The step is to set your IDE to identify 

your Arduino Uno. 

 

http://arduino.cc/en/Guide/Windows
http://arduino.cc/en/Guide/MacOSX
http://www.arduino.cc/playground/Learning/Linux


 
 

 

GUI (Graphical User Interface) 

 

Verify  

Checks your code for errors compiling it. 

 

Upload  

Compiles your code and uploads it to the configured board. See uploading below for details. 

Note: If you are using an external programmer with your board, you can hold down the "shift" key 

on your computer when using this icon. The text will change to "Upload using Programmer" 

 

New  

Creates a new sketch. 

 

Open  

Presents a menu of all the sketches in your sketchbook. Clicking one will open it within the current 

window overwriting its content. 

Note: due to a bug in Java, this menu doesn't scroll; if you need to open a sketch late in the list, 

use the File | Sketchbookmenu instead. 

 

Save  

Saves your sketch. 

 

Serial Monitor  

Opens the serial monitor. 

 

 

 

 

 

STEP-5: Select your board: Arduino Uno 

 

https://www.arduino.cc/en/guide/environment#uploading
https://www.arduino.cc/en/guide/environment#serialmonitor


 
 

 

STEP-6: Select your Serial Device 

 

Windows:  Select the serial device of the Arduino board from the Tools | Serial Port menu. This is 

likely to be com3 or higher (COM1 and COM2 are usually reserved for hardware serial ports). To 

find out, you can disconnect your Arduino board and re-open the menu; the entry that 

disappears should be the Arduino board. Reconnect the board and select that serial port. 

 

 
 

Mac OS: Select the serial device of the Arduino board from the Tools > Serial Port menu. On the 

Mac, this should be something with /dev/tty.usbmodem (for the Uno or Mega 2560) or 

/dev/tty.usbserial (for older boards) in it. 

 

Linux: http://playground.arduino.cc/Learning/Linux 

 

 

 

http://playground.arduino.cc/Learning/Linux


About Quad Store’s Arduino-Compatible 

 Uno R3 board 
What's on the board? 

There are many varieties of Arduino boards that can be used for different purposes. Some boards 

look a bit different from the one below, but most Arduino have the majority of these components 

in common: 

 

 
 

Power (USB / Barrel Jack) 

Every Arduino board needs a way to be connected to a power source. The Arduino UNO can be 

powered from a USB cable coming from your computer or a wall power supply that is terminated 

in a barrel jack. In the picture above the USB connection is labeled (1) and the barrel jack is 

labeled (2). 

. 

NOTE: Do NOT use a power supply greater than 20 Volts as you will overpower (and thereby 

destroy) your Arduino. The recommended voltage for most Arduino models is between 6 and 12 

Volts. 

Pins (5V, 3.3V, GND, Analog, Digital, PWM, AREF) 

 

The pins on your Arduino are the places where you connect wires to construct a circuit (probably 

in conjuction with a breadboard and some wire. They usually have black plastic ‘headers’ that 

allow you to just plug a wire right into the board. The Arduino has several different kinds of pins, 

each of which is labeled on the board and used for different functions. 

• GND (3): Short for ‘Ground’. There are several GND pins on the Arduino, any of which can 

be used to ground your circuit. 

• 5V (4) & 3.3V (5): As you might guess, the 5V pin supplies 5 volts of power, and the 3.3V pin 

supplies 3.3 volts of power. Most of the simple components used with the Arduino run 

happily off of 5 or 3.3 volts. 

• Analog (6): The area of pins under the ‘Analog In’ label (A0 through A5 on the UNO) are 

Analog In pins. These pins can read the signal from an analog sensor (like a temperature 

sensor) and convert it into a digital value that we can read. 



• Digital (7): Across from the analog pins are the digital pins (0 through 13 on the UNO). These 

pins can be used for both digital input (like telling if a button is pushed) and digital output 

(like powering an LED). 

• PWM (8): You may have noticed the tilde (~) next to some of the digital pins (3, 5, 6, 9, 10, 

and 11 on the UNO). These pins act as normal digital pins, but can also be used for 

something called Pulse-Width Modulation (PWM). We have a tutorial on PWM, but for now, 

think of these pins as being able to simulate analog output (like fading an LED in and out). 

• AREF (9): Stands for Analog Reference. Most of the time you can leave this pin alone. It is 

sometimes used to set an external reference voltage (between 0 and 5 Volts) as the upper 

limit for the analog input pins. 

 

Reset Button 

Just like the original Nintendo, the Arduino has a reset button (10). Pushing it will temporarily 

connect the reset pin to ground and restart any code that is loaded on the Arduino. This can be 

very useful if your code doesn’t repeat, but you want to test it multiple times. Unlike the original 

Nintendo however, blowing on the Arduino doesn’t usually fix any problems. 

 

Power LED Indicator 

Just beneath and to the right of the word “UNO” on your circuit board, there’s a tiny LED next to 

the word ‘ON’ (11). This LED should light up whenever you plug your Arduino into a power source. If 

this light doesn’t turn on, there’s a good chance something is wrong. Time to re-check your circuit! 

 

TX RX LEDs 

TX is short for transmit, RX is short for receive. These markings appear quite a bit in electronics to 

indicate the pins responsible for serial communication. In our case, there are two places on the 

Arduino UNO where TX and RX appear – once by digital pins 0 and 1, and a second time next to 

the TX and RX indicator LEDs (12). These LEDs will give us some nice visual indications whenever our 

Arduino is receiving or transmitting data (like when we’re loading a new program onto the board). 

 

 

Main IC 

The black thing with all the metal legs is an IC, or Integrated Circuit (13). Think of it as the brains of 

our Arduino. The main IC on the Arduino is slightly different from board type to board type, but is 

usually from the ATmega line of IC’s from the ATMEL company. This can be important, as you may 

need to know the IC type (along with your board type) before loading up a new program from 

the Arduino software. This information can usually be found in writing on the top side of the IC. If 

you want to know more about the difference between various IC’s, reading the datasheets is 

often a good idea. 

 

Voltage Regulator 

The voltage regulator (14) is not actually something you can (or should) interact with on the 

Arduino. But it is potentially useful to know that it is there and what it’s for. The voltage regulator 

does exactly what it says – it controls the amount of voltage that is let into the Arduino board. Think 

of it as a kind of gatekeeper; it will turn away an extra voltage that might harm the circuit. Of 

course, it has its limits, so don’t hook up your Arduino to anything greater than 20 volts. 
 

 

Lesson-0: Add Libraries 
 

Once you are comfortable with the Arduino software and using the built-in functions, 

you may want to extend its functionality with additional libraries. 



 
What are Libraries? 

Libraries are a collection of code that makes it easy for you to connect to a sensor, display, 

module, etc. For example, the built-in LiquidCrystal library makes it easy to talk to character 

LCD displays. There are hundreds of additional libraries available on the Internet for 

download. The built-in libraries and some of these additional libraries are listed in the 

reference. To use these additional libraries, you will need to install them. 

How to Install a Library 

Using the Library Manager 

To install a new library into your Arduino IDE, you can use the Library Manager (available 

from IDE version 1.6.2). Open the IDE and click Sketch > Include > Library > Manage Libraries. 

 

The library manager will open and you will find a list of libraries that are already installed or 



 

ready for installation. In this example, we will install the Bridge library. Scroll down the list to 

find it, then select the version of the library you want to install. Sometimes, only one version of 

the library is available. If the version selection menu does not appear, don't worry; it is 

normal. 

 

Finally click on install and wait for the IDE to install the new library. Downloading may take 

time depending on your connection speed. Once it has finished, an Installed tag should 

appear next to the Bridge library. You can close the library manager. 

 

 

You can now find the new library available in the Include Library menu. If you want to add 

your own library open a new issue on github. 



 

Importing a .zip Library 

Libraries are often distributed as a ZIP file or folder. The name of the folder is the name of the 

library. Inside the folder will be the following: .cpp file, .h file, often a keywords.txt file, 

examples folder, and other files required by the library. Starting with version 1.0.5, you can 

install third-party libraries in the IDE. Do not unzip the downloaded library; leave it as-is. 

In the Arduino IDE, navigate to Sketch > Include Library > Add .ZIP Library. 
 

You will be prompted to select the library you would like to add. Navigate to the .zip file's 

location and open it. 

Return to the Sketch > Import Library menu. You should now see the library at the bottom of 

the drop-down menu. It is ready to be used in your sketch. The zip file will have been 

expanded in the libraries folder in your Arduino sketches directory. 

NB: The Library will be available to use in sketches, but examples for the library will not be 

shown in the File > Examples until after the IDE has restarted. 

 
 

Manual installation 

To install the library, first, quit the Arduino application. Then unzip the ZIP file containing the 

library. For example, if you're installing a library called "ArduinoParty", uncompress 

ArduinoParty.zip. It should contain a folder called ArduinoParty, with files like 

ArduinoParty.cpp and ArduinoParty.h inside. (If the .cpp and .h files aren't in a folder, you'll 

need to create one. In this case, you'd make a folder called "ArduinoParty" and move into it 

all the files that were in the ZIP file, like ArduinoParty.cpp and ArduinoParty.h.) 

Drag the ArduinoParty folder into this folder (your libraries folder). Under Windows, it will likely 



 

be called "My Documents\Arduino\libraries". For Mac users, it will likely be called 

"Documents/Arduino/libraries". On Linux, it will be the "libraries" folder in your sketchbook. 

Your Arduino library folder should now look like this (on Windows): 

My Documents\Arduino\libraries\ArduinoParty\ArduinoParty.cpp 

My Documents\Arduino\libraries\ArduinoParty\ArduinoParty.h 

My Documents\Arduino\libraries\ArduinoParty\examples 

.... 

 

 
or like this (on Mac and Linux): 

Documents/Arduino/libraries/ArduinoParty/ArduinoParty.cpp 

Documents/Arduino/libraries/ArduinoParty/ArduinoParty.h 

Documents/Arduino/libraries/ArduinoParty/examples 

.... 

There may be more files than just the .cpp and .h files so make sure they're all there. (The 

library won't work if you put the .cpp and .h files directly into the libraries folder or if they're 

nested in an extra folder. For example: Documents\Arduino\libraries\ArduinoParty.cpp and 

Documents\Arduino\libraries\ArduinoParty\ArduinoParty\ArduinoParty.cpp won't work.) 

Restart the Arduino application. Make sure the new library appears in the Sketch > Import 

Library menu. That's it. You've installed a library! 

 
 

Summary 

In this lesson, we will install all the libraries that we will use in the tutorial. Open the libraries 

folder and install the ZIP files one by one so we won't need to do this step in the following 

lessons. We just connect the component as the schematic and upload the code provided. 

Then the kit will work. 



Lesson 1- Blink from the board 
 
 

Overview 

In this lesson, you will learn how program your UNO R3 controller board to make the 

Arduino's built-in LED blink. 

 

Component Required: 

(1) x Uno R3 and USB cable 

 

 
Principle 

The UNO R3 board has rows of connectors along both sides that are used to connect to 

several electronic devices and plug-in 'shields' that extends its capability. 

 

It also has a single LED that you can control from your sketches. This LED is built onto the UNO 

R3 board and is often referred to as the 'L' LED as this is how it is labeled on the board. 

 

 

 

 

 



You may find that your UNO R3 board 's 'L' LED already blinks when you connect it to a USB 

plug. This is because the boards are generally shipped with the 'Blink' sketch pre-installed. 

In this lesson, we will reprogram the UNO R3 board with our own Blink sketch and then 

change the rate at which it blinks. 

In Lesson 0, you set up your Arduino IDE and made sure that you could find the right serial 

port for it to connect to your UNO R3 board. The time has now come to put that connection 

to the test and program your UNO R3 board. 

The Arduino IDE includes a large collection of example sketches that you can load up and 

use. This includes an example sketch for making the 'L' LED blink. 

Load the 'Blink' sketch that you will find in the IDE's menu system under File > Examples > 

01.Basics 

When the sketch window opens, enlarge it so that you can see the entire sketch in the 

window. 



 

 
 

The example sketches included with the Arduino IDE are 'read-only'. That is, you can upload 

them to an UNO R3 board, but if you change them, you cannot save them as the same file. 

Since we are going to change this sketch, the first thing you need to do is save your own 

copy. 

From the File menu on the Arduino IDE, select 'Save As..' and then save the sketch with the 

name 'MyBlink'. 

You have saved your copy of 'Blink' in your sketchbook. This means that if you ever want to 



 

find it again, you can just open it using the File > Sketchbook menu option. 
 

Attach your Arduino board to your computer with the USB cable and check that the 'Board 

Type' and 'Serial Port' are set correctly. You may need to refer back to Lesson 0. 

The Arduino IDE will show you the current settings for board at the bottom of the window. 
 

Click on the 'Upload' button. The second button from the left on the toolbar. 
 

If you watch the status area of the IDE, you will see a progress bar and a series of messages. 

At first, it will say 'Compiling Sketch...'. This converts the sketch into a format suitable for 

uploading to the board. 

 

Next, the status will change to 'Uploading'. At this point, the LEDs on the Arduino should start 

to flicker as the sketch is transferred. 



 

 
 

Finally, the staus will change to 'Done'. 
 

The other message tells us that the sketch is using 1,084 bytes of the 32,256 bytes available. 

After the 'Compiling Sketch..' stage you could get the following error message: 

 
 

It can mean that your board is not connected at all, or the drivers have not been installed (if 

necessary) or that the wrong serial port is selected. 

If you encounter this, go back to Lesson 0 and check your installation. 

Once the upload has completed, the board should restart and start blinking. 

Open the code 

Note that a huge part of this sketch is composed of comments. These are not actual 

program instructions; rather, they just explain how the program works. They are there for your 

benefit. 

Everything between /* and */ at the top of the sketch is a block comment; it explains what 

the sketch is for. 

Single line comments start with // and everything up until the end of that line is considered a 

comment. 

The first line of code is: 



 

int led = 13; 

As the comment above it explains, this is giving a name to the pin that the LED is attached 

to. This is 13 on most Arduinos, including the UNO and Leonardo. 

Next, we have the 'setup' function. Again, as the comment says, this is executed when the 

reset button is pressed. It is also executed whenever the board resets for any reason, such as 

power first being applied to it, or after a sketch has been uploaded. 

void setup() { 

// initialize the digital pin as an output. 

pinMode(led, OUTPUT); 

} 

Every Arduino sketch must have a 'setup' function, and the place where you might want to 

add instructions of your own is between the { and the }. 

In this case, there is just one command there, which, as the comment states tells the Arduino 

board that we are going to use the LED pin as an output. 

It is also mandatory for a sketch to have a 'loop' function. Unlike the 'setup' function that only 

runs once, after a reset, the 'loop' function will, after it has finished running its commands, 

immediately start again. 

void loop() { 

digitalWrite(led, HIGH); // turn the LED on (HIGH is the voltage level) 

delay(1000);  // wait for a second 

digitalWrite(led, LOW); // turn the LED off by making the voltage LOW 

delay(1000);  // wait for a second 

} 

Inside the loop function, the commands first of all turn the LED pin on (HIGH), then 'delay' for 

1000 milliseconds (1 second), then turn the LED pin off and pause for another second. 

You are now going to make your LED blink faster. As you might have guessed, the key to this 

lies in changing the parameter in () for the 'delay' command. 



 

 
 

This delay period is in milliseconds, so if you want the LED to blink twice as fast, 

change the value from 1000 to 500. This would then pause for half a second each 

delay rather than a whole second. 

Upload the sketch again and you should see the LED start to blink more quickly. 


